Suporte não-oficial ao OcoMon

Criado e mantido por usuários para usuários
 
InícioInício  PortalPortal  CalendárioCalendário  FAQFAQ  BuscarBuscar  MembrosMembros  GruposGrupos  Registrar-seRegistrar-se  Conectar-se  
Últimos assuntos
» FeedBack do usuario
Sex Jul 07, 2017 8:25 am por vafonseca

» Paramentrização Ocomon
Sex Maio 05, 2017 12:51 pm por cristiano.barbosa

» Erro OCOMON perfil criado não aparece
Qua Maio 03, 2017 12:29 pm por rodrigo.guimaraes

» Ocomon não conecta a base apos Servidor Desligar sozinho [Resolvido]
Ter Abr 25, 2017 5:25 pm por leonardocr

» Tela em branco após login no navegador IE
Ter Abr 11, 2017 8:52 am por FabioRK

» [Resolvido] Assentamento no Relatório
Sex Fev 17, 2017 12:39 pm por renatomdm

» Upload de base de dados com 2 Gb
Qua Fev 08, 2017 12:07 pm por alex.xavier

» Grupo Ocomon no telegram
Seg Jan 02, 2017 12:07 pm por leandroz3ta

» Fazer Insert de Area e Problemas
Qui Dez 29, 2016 12:58 pm por FabioRK


Compartilhe | 
 

 HELP-Ocomon não envia e-mail na abertura e fechamento de chamado.

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
altair junior



Mensagens : 7
Data de inscrição : 01/09/2015
Idade : 22

01092015
MensagemHELP-Ocomon não envia e-mail na abertura e fechamento de chamado.

Boa Tarde galera, primeira vez que uso sistema ocomon , estou utilizando ele na plataforma Windows com XAMPP, instalei ele todo certinho e só estou tendo problemas na parte de configuração de e-mail. Aqui na empresa usamos o gmail da google, as configurações no ocomon eu deixei da seguinte maneira.



Quando vou abrir o chamado clico no Ok, ele me da a seguinte mensagem
"A mensagem não pôde ser enviada.
Mailer Error: SMTP Error: Could not connect to SMTP host."


Então fui pesquisar e vi que tem como retirar essa mensagem deixando comentado as linhas no arquivo  "/xampp/htdocs/ocomon/includes/functions/funcoes.inc" Da certo e a mensagem de erro para de aparecer e ele abre o chamado normal informando que o chamado foi aberto com sucesso e qual e o numero do chamado, más ainda assim ele não envia um e-mail para o usuário e para o técnico sobre o chamado. Então vi para trocar a porta 25 que e de padrão do ocomon pela do gmail que pode ser 465 ou 587, então fui até o local no arquivo que se encontra em ".ocomon\includes\phpmailer\class.phpmailer.php" e modifiquei a porta 25 e testei com ambas portas 465 e depois 587, quando vou abrir o chamado ele fica carregando um pouco não aparece nenhuma mensagem de erro nem que o chamado foi aberto, apenas fica na pagina do chamado más ele abre o chamado, más não envia o e-mail mesmo assim. Alguém sabe o que pode ser? talvez possa ser meu firewall bloqueando? Porque eu não sei mais qual pode ser a causa do problema, espero que possam me ajudar, desde já, obrigado!
Voltar ao Topo Ir em baixo
Ver perfil do usuário

 Tópicos similares

-
» Formulário que envia para o e-mail
» Não consigo enviar e-mail em massa
» Nome de usuario, e-mail e senha somem quando passa o mouse
» Usuário receber e-mail a cada período de tempo
» Como desativar a ativação de conta por e-mail
Compartilhar este artigo em: BookmarksDiggRedditDel.icio.usGoogleLiveSlashdotNetscapeTechnoratiStumbleUponNewsvineFurlYahoo!Smarking

HELP-Ocomon não envia e-mail na abertura e fechamento de chamado. :: Comentários

Altair.

Tenta colocar essa configuração no endereço SMTP:
ssl://smtp.gmail.com:465
Fabio,

Fiz do jeito que você falou e ele apresentou o seguinte erro

Altair verifica as seguintes questões:
- Vocês está usando o sistema em Windows ou Linux?
- Na tua rede/PC tem algum firewall ou antivírus?
- A extensão ssl está habilitada no PHP (php.ini - extension=php_openssl.dll) ?
Fabio,
Estou com sistema Windows
Temos um Firewall no linux tudo passa por ele, más já liberei todas as permissões possíveis
Já ativei ela , e mesmo assim o erro persiste, não sei mais o que possa ser Sad

Altair.
Outro teste que você pode fazer é através de telnet, para ver se a comunicação com o smtp está ocorrendo.
No prompt de comando digita: telnet smtp.gmail.com 587 ou telnet smtp.gmail.com 465

Caso você não tenha o telnet instalado vai no Painel de Controle > Programas e Recursos > Ativar ou Desativar recursos do Windows e marca Cliente Telnet
Fabio,



587 Obtive essa resposta no 2 promt , e o 465 não obtive nenhuma resposta
Então não é bloqueio.
Na porta 587 conectou.
Tenta colocar somente: smtp.gmail.com:587
coloquei e mesmo assim fica dando a mensagem
A mensagem não pôde ser enviada.
Mailer Error: SMTP Error: Could not connect to SMTP host.


Acho que vou desistir do ocomon, tudo funciono perfeitamente menos a parte do e-mail e não tem mais pra onde recorrer, não sei qual o motivo do erro
Os demais dados estão corretos? Essa conta existe no gmail?
Sim, testei ate outras contas e mesmo assim nada. Vou falar todos os procedimentos que fiz.

No painel Admin do ocomon no Endereço SMTP, eu tentei de varias formas e nenhum deu certo.

Nas configurações:
C:\xampp\php\php.ini

Habilitei o SSl. Mais embaixo achei as seguintes linhas:
[mail function]
; For Win32 only.
SMTP =
smtp_port = 465

; For Win32 only.
;sendmail_from =

Fiz o teste colocando o e-mail e a porta para ve se ia más não obtive sucesso, testei ambas portas 465/587. Não sei mais o que pode ser feito.

O único avanço que tive foi seguinte, quando eu usei o e-mail com a porta 465 e abri o chamado ele abriu o chamado e não deu aquele mensagem de erro "A mensagem não pôde ser enviada. Mailer Error: SMTP Error: Could not connect to SMTP host." Más também não deu nenhuma mensagem falando que chamado foi aberto com sucesso e muito menos envio e-mail, simplesmente abriu o chamado sem dar nenhum tipo de mensagem.
Acredito que as mensagens de erro não estão aparecendo pela modificação que você fez na função.
Volta com o backup dos arquivos originais e testa de novo.
Boa Tarde Fabio,

Eu havia abandonando o sistema ocomon, más hoje resolvi voltar, eu formatei a máquina instalei o windows novamente, instalei o xampp e o ocomon de novo e não mexi em mais nada. A primeira coisa que fui mexer foi no e-mail, configurei a parte do SMTP no ocomon conforme você me falou e depois habilitei o ssl no arquivo php.ini, foram as única alterações que eu fiz, quando fui testar ele me deu a seguinte mensagem de erro.

Warning: fsockopen() [function.fsockopen]: unable to connect to ssl://smtp.gmail.com:465 (Unable to find the socket transport "ssl" - did you forget to enable it when you configured PHP?) in C:\xampp\htdocs\Ocomon\includes\phpmailer\class.smtp.php on line 122
A mensagem não pôde ser enviada.
Mailer Error: SMTP Error: Could not connect to SMTP host.


Dessa vez tem que funcionar, porque eu instalei tudo do zero e não modifiquei nada. Espero seu retorno, obrigado !
Altair.

Depois de habilitar o SSL no PHP vc reiniciou o serviço?
Tenta retirar o ssl do início da configuração.
No outro teste que vc fez com telnet na porta 465 não havia conectado, verifica se no teu firewall essa porta está liberada.
 

HELP-Ocomon não envia e-mail na abertura e fechamento de chamado.

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 

Página 1 de 1

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
Suporte não-oficial ao OcoMon :: Sua primeira categoria :: GERAL :: F.A.Q-
Ir para: