Suporte não-oficial ao OcoMon

Criado e mantido por usuários para usuários
 
InícioInício  PortalPortal  CalendárioCalendário  FAQFAQ  BuscarBuscar  MembrosMembros  GruposGrupos  Registrar-seRegistrar-se  Conectar-se  
Últimos assuntos
» Área e Problemas do Consultar igual ao de Abrir chamado
Ter Set 12, 2017 8:53 am por renatomdm

» FeedBack do usuario
Sex Jul 07, 2017 8:25 am por vafonseca

» Paramentrização Ocomon
Sex Maio 05, 2017 12:51 pm por cristiano.barbosa

» Erro OCOMON perfil criado não aparece
Qua Maio 03, 2017 12:29 pm por rodrigo.guimaraes

» Ocomon não conecta a base apos Servidor Desligar sozinho [Resolvido]
Ter Abr 25, 2017 5:25 pm por leonardocr

» Tela em branco após login no navegador IE
Ter Abr 11, 2017 8:52 am por FabioRK

» [Resolvido] Assentamento no Relatório
Sex Fev 17, 2017 12:39 pm por renatomdm

» Upload de base de dados com 2 Gb
Qua Fev 08, 2017 12:07 pm por alex.xavier

» Grupo Ocomon no telegram
Seg Jan 02, 2017 12:07 pm por leandroz3ta


Compartilhe | 
 

 Problemas com acentuação nas páginas

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
kleberasouza



Mensagens : 2
Data de inscrição : 02/09/2011

MensagemAssunto: Problemas com acentuação nas páginas   Sex Set 02, 2011 1:31 pm

Boa tarde Pessoal.

Estou prestes a implantar o Ocomon na empresa onde trabalho, porém, na fase de testes, deparei-me com a seguinte situação:
Após logar no sistema, são exibidas as solicitações para atendimento.
Ao selecionar qualquer das solicitações exisitentes, são exibidos os detalhes da mesma, porem, caso seja necessário alterar, adicionar um assentamento ou dar andamento ao atendimento incluindo novas informações no campo descrição, caso este possua algum caracter com acentuação, o sistema retorna o seguinte erro:
NÃO FOI POSSÍVEL GRAVAR AS INFORMAÇÕES DE EDIÇÃO DO CHAMADO!
INSERT INTO assentamentos (ocorrencia, assentamento, data, responsavel, asset_privated) values (1, 'Ocorrência encaminhada/alterada por admin', '2011-09-02 13:24:07', 1, 0).

Retirando a acentuação da palavra Ocorrência, o registro é feito com sucesso.

Já tentei alterar diretamente na tabela ASSENTAMENTO através do MySQL e consegui fazê-lo com sucesso. Inclusive ao listar, as informações que possuem acentuação são exibidas normalmente.

Já tentei alterar o formato da tabela, o tipo do campo, mas tudo sem sucesso.
Outro detalhe que acredito ser importante citar é com relação ao cabeçalho das colunas exibido nos detalhes da ocorrência registrada.
Os mesmos também são exibidos com caracterer que lembram o sinal de interrogação "?", porém, na tela de listagem inical das ocorrências registradas, isso não acontece, sendo exibidas as informações normalmente.

Será que algum de nossos colegas já passou situação semelhante ?!
Aguardo uma luz no fim do tunel.

Desde já agradeço a colaboração de quem puder ajudar.

Kleber Souza
Voltar ao Topo Ir em baixo
Ver perfil do usuário
adrianacombat



Mensagens : 12
Data de inscrição : 28/11/2011

MensagemAssunto: Acentuação   Seg Nov 28, 2011 11:05 am

Olá!!!

Estava com este problema tb, veja como resolver:

Entre no arquivo php.ini, procure por iso, quando achar troque as linhas abaixo

; PHP's built-in default is text/html
default_mimetype = "text/html"
;default_charset = "iso-8859-1"

por

; PHP's built-in default is text/html
default_mimetype = "text/html"
default_charset = "iso-8859-1"

OK
Voltar ao Topo Ir em baixo
Ver perfil do usuário
kleberasouza



Mensagens : 2
Data de inscrição : 02/09/2011

MensagemAssunto: Erro de acentuação   Ter Jan 03, 2012 4:07 pm

Olá adrianacombat.
Agradeço suas informações, no entanto, tentei estas alterações, porém, sem sucesso.
Se tiver alguma outra dica agradeço.

Kleber Souza.



adrianacombat escreveu:
Olá!!!

Estava com este problema tb, veja como resolver:

Entre no arquivo php.ini, procure por iso, quando achar troque as linhas abaixo

; PHP's built-in default is text/html
default_mimetype = "text/html"
;default_charset = "iso-8859-1"

por

; PHP's built-in default is text/html
default_mimetype = "text/html"
default_charset = "iso-8859-1"

OK
Voltar ao Topo Ir em baixo
Ver perfil do usuário
andrebolzan



Mensagens : 3
Data de inscrição : 13/12/2011

MensagemAssunto: Re: Problemas com acentuação nas páginas   Qui Jan 05, 2012 11:08 am

kleberasouza escreveu:
Olá adrianacombat.
Agradeço suas informações, no entanto, tentei estas alterações, porém, sem sucesso.
Se tiver alguma outra dica agradeço.

Kleber Souza.



adrianacombat escreveu:
Olá!!!

Estava com este problema tb, veja como resolver:

Entre no arquivo php.ini, procure por iso, quando achar troque as linhas abaixo

; PHP's built-in default is text/html
default_mimetype = "text/html"
;default_charset = "iso-8859-1"

por

; PHP's built-in default is text/html
default_mimetype = "text/html"
default_charset = "iso-8859-1"

OK


Amigo eu utilizo essa configuração no apache não no PHP, você pode adicionar esse parametro no final do arquivo apache2.conf

Código:
#definição de codificação padrão
AddDefaultCharset ISO-8859-1

Depois reinicie o serviço do apache.

Abraços
Voltar ao Topo Ir em baixo
Ver perfil do usuário
gxavier.bh



Mensagens : 17
Data de inscrição : 27/08/2013

MensagemAssunto: Não grava no banco se tiver caracter especial   Qua Ago 28, 2013 8:33 am

Hoje joguei a toalha. Depois de anos instalando Ocomon por ai eu jogo a toalha.
Se você coloca 8859-1 as páginas entram sem problemas, mas nada acentuado vai para o banco - fica campo em branco. Se coloco UTF8, as paginas entram com "?" no lugar de tudo que é caractere acentuado ou especial, ai tudo que se coloca acentuado nos campos de formulário vão para o banco normalmente.
Li e fiz tudo que se falou neste e em outros foruns e nada.
Alguma sugestão diferente?
Servidor Windows 2008 R2
Xampp com php 5.4.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
julius-df



Mensagens : 2
Data de inscrição : 03/09/2013

MensagemAssunto: Re: Problemas com acentuação nas páginas   Ter Set 03, 2013 8:41 am

Mesmo problema aqui...
Já fiz tudo que existe na Internet referente a esse problema da acentuação. Se coloco UTF-8 alguns caracteres aparecem como um quadradinho, ou como ?. Se altero para ISO-8559-1 esse problema arruma, mas caracteres de acentuação e ç ficam em brancos no banco. Já alterei o .htaccess do ocomon, php.ini, apache.conf. Enfim tudoOOo.

Alguma outra solução, como vocês conseguiram usar isso?

Utilizo xampp 1.8.2 em Windows 2008 Srv.

Abraços.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
gxavier.bh



Mensagens : 17
Data de inscrição : 27/08/2013

MensagemAssunto: Acentuação   Sex Set 06, 2013 5:07 pm

Voltar ao Topo Ir em baixo
Ver perfil do usuário
julius-df



Mensagens : 2
Data de inscrição : 03/09/2013

MensagemAssunto: Re: Problemas com acentuação nas páginas   Ter Set 10, 2013 3:00 pm

A solução para mim foi um downgrade na versão do XAMPP.
Então eu desci do mais atual, para o 2.4. Ai funcionou de primeira!
Acredito que é algum problema na versão do Php, que de forma alguma conseguimos resolver fazendo os passos mostrados em todos os blogs e sites.
Triste essa pala do Ocomon.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
rschaferinfo



Mensagens : 4
Data de inscrição : 11/06/2012
Localização : Curitiba - PR

MensagemAssunto: Re: Problemas com acentuação nas páginas   Seg Set 16, 2013 10:48 am

gxavier.bh escreveu:
Hoje joguei a toalha. Depois de anos instalando Ocomon por ai eu jogo a toalha.
Se você coloca 8859-1 as páginas entram sem problemas, mas nada acentuado vai para o banco - fica campo em branco. Se coloco UTF8, as paginas entram com "?" no lugar de tudo que é caractere acentuado ou especial, ai tudo que se coloca acentuado nos campos de formulário vão para o banco normalmente.
Li e fiz tudo que se falou neste e em outros foruns e nada.
Alguma sugestão diferente?
Servidor Windows 2008 R2
Xampp com php 5.4.
Chegou a tentar mudar a função? como no post abaixo?
http://ocomon.forumbrasil.net/t753-erro-ao-salvar-campos-com-acento-ou-c

Isso resolveu meu problema, procure e modifique a tal função no arquivo.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
gxavier.bh



Mensagens : 17
Data de inscrição : 27/08/2013

MensagemAssunto: Acentuação no banco   Seg Set 16, 2013 12:10 pm

Resolvi meu problema convertendo todos os arquivos PHP para utf8, tinha muito em ANSI, fiz o backup do banco com arquivo .SQL, editei o arquivo, troquei tudo para UTF8 e subi de volta para o MySQL.
Funcionou.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Conteúdo patrocinado




MensagemAssunto: Re: Problemas com acentuação nas páginas   

Voltar ao Topo Ir em baixo
 
Problemas com acentuação nas páginas
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» Problemas com visualização de páginas HTML
» Páginas do fórum não param de carregar
» Problemas com colorir fundo
» Problemas com cores de títulos em css
» Problemas no ' sub endereço '

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
Suporte não-oficial ao OcoMon :: Sua primeira categoria :: GERAL :: Versões e Atualizações-
Ir para: