Suporte não-oficial ao OcoMon

Criado e mantido por usuários para usuários
 
InícioInício  PortalPortal  CalendárioCalendário  FAQFAQ  BuscarBuscar  MembrosMembros  GruposGrupos  Registrar-seRegistrar-se  Conectar-se  
Últimos assuntos
» FeedBack do usuario
Sex Jul 07, 2017 8:25 am por vafonseca

» Paramentrização Ocomon
Sex Maio 05, 2017 12:51 pm por cristiano.barbosa

» Erro OCOMON perfil criado não aparece
Qua Maio 03, 2017 12:29 pm por rodrigo.guimaraes

» Ocomon não conecta a base apos Servidor Desligar sozinho [Resolvido]
Ter Abr 25, 2017 5:25 pm por leonardocr

» Tela em branco após login no navegador IE
Ter Abr 11, 2017 8:52 am por FabioRK

» [Resolvido] Assentamento no Relatório
Sex Fev 17, 2017 12:39 pm por renatomdm

» Upload de base de dados com 2 Gb
Qua Fev 08, 2017 12:07 pm por alex.xavier

» Grupo Ocomon no telegram
Seg Jan 02, 2017 12:07 pm por leandroz3ta

» Fazer Insert de Area e Problemas
Qui Dez 29, 2016 12:58 pm por FabioRK


Compartilhe | 
 

 [RESOLVIDO]OcoMon não abre a página inicial de logon

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
claudevan



Mensagens : 14
Data de inscrição : 09/04/2015
Idade : 43

MensagemAssunto: [RESOLVIDO]OcoMon não abre a página inicial de logon   Qui Abr 09, 2015 10:50 pm

Boa noite,

Instalei o OcoMon no CentOS tudo normal na instalação, mais a pagina inicial de logon não abre da tela branca com essa mensagem abaixo.

Unknown MySQL server host 'SQL_SERVER' (1)

Por favor quem poder ajudar eu agradeço.

Desde já obrigado!


Última edição por claudevan em Dom Abr 12, 2015 8:51 pm, editado 1 vez(es)
Voltar ao Topo Ir em baixo
Ver perfil do usuário
FabioRK

avatar

Mensagens : 371
Data de inscrição : 14/09/2009
Idade : 37
Localização : Carazinho - RS

MensagemAssunto: Re: [RESOLVIDO]OcoMon não abre a página inicial de logon   Sex Abr 10, 2015 8:19 am

Claudevan você precisa ajustar o arquivo ocomon/includes/config.inc.php com as configurações corretas do seu banco de dados.
No caso esse erro é porque o sistema não localizou o local da base de dados informada.
Caso o banco esteja no mesmo servidor da página pode deixar localhost.
Código:
define ("SQL_SERVER", "localhost");
Voltar ao Topo Ir em baixo
Ver perfil do usuário
claudevan



Mensagens : 14
Data de inscrição : 09/04/2015
Idade : 43

MensagemAssunto: OcoMon não abre a página inicial   Sex Abr 10, 2015 4:39 pm

opa cara meu arquivo esta assim!!!


//Usuario do banco
define ( "SQL_USER", "root"); //NOME DO USUÁRIO PARA ACESSAR A BASE DO OCOMON - ESSE USUÁRIO É CRIADO AUTOMATICAMENTE NA INSTALACAO DO SISTEMA!!

//Senha do banco
define ( "SQL_PASSWD", "214597c");//ESSA SENHA É A SENHA PADRAO CRIADA NA INSTALACAO DO SISTEMA. É RECOMENDÁVEL A ALTERACAO DA MESMA NO MYSQL.
//Servidor do banco
define ( "SQL_SERVER", "localhost"); //SE O BANCO DE DADOS ESTIVER EM UM SERVIDOR DIFERENTE DO SERVIDOR WEB DEVE-SE ALTERAR O VALOR "localhost"
//Nome do banco
define ( "SQL_DB", "ocomon_rc6");//NOME DO BANCO DE DADOS. O PADRÃO DESSA VERSÃO É: ocomon_rc6

Voltar ao Topo Ir em baixo
Ver perfil do usuário
claudevan



Mensagens : 14
Data de inscrição : 09/04/2015
Idade : 43

MensagemAssunto: OcoMon não abre a página inicial de logon   Sex Abr 10, 2015 5:12 pm

Cara comecei tudo novamente do zero e recebo outro erro bem parecido!

Can't connect to MySQL server on 'SQL_SERVER' (4)


Desde já obrigado pela ajuda!
Voltar ao Topo Ir em baixo
Ver perfil do usuário
FabioRK

avatar

Mensagens : 371
Data de inscrição : 14/09/2009
Idade : 37
Localização : Carazinho - RS

MensagemAssunto: Re: [RESOLVIDO]OcoMon não abre a página inicial de logon   Sex Abr 10, 2015 6:29 pm

E o serviço do banco mysql está rodando no servidor?

Voltar ao Topo Ir em baixo
Ver perfil do usuário
claudevan



Mensagens : 14
Data de inscrição : 09/04/2015
Idade : 43

MensagemAssunto: OcoMon não abre a página inicial de logon   Sex Abr 10, 2015 11:01 pm

Fabio cara o banco esta ativo como você pode vê no comando abaixo:

[root@localhost ~]# mysqladmin -u root -p ping
Enter password:
mysqld is alive
[root@localhost ~]#


Porem tem algo de errado, quando eu dou outro comando para testar o banco, é como se a senha de root estiveci errada. a senha de root é 214597c no comando acima eu precisei colocar ela pra dá permissão ao comando, o que pode esta errado cara?

[root@localhost ~]# mysql mysql
ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)
[root@localhost ~]#


Desde já obrigado!
Voltar ao Topo Ir em baixo
Ver perfil do usuário
claudevan



Mensagens : 14
Data de inscrição : 09/04/2015
Idade : 43

MensagemAssunto: Re: [RESOLVIDO]OcoMon não abre a página inicial de logon   Sab Abr 11, 2015 11:15 pm

ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)

O erro acima foi apresentado porque eu estava usando senha, enão deixei o usuário "root" sem senha e apresentou a tela de logon do OcoMon para colocar usuário e senha, porem quando eu coloco usuário: admin e senha: admin apareci uma pagina em branco com a seguinte mensagem: "No database selected".

Meu arquivo esta configurado assim:

/var/www/html/ocomon/includes/config.inc.php

//Usuario do banco
define ( "SQL_USER", "root"); //NOME DO USUÁRIO PARA ACESSAR A BASE DO OCOMON - ESSE USUÁRIO É CRIADO AUTOMATICAMENTE NA INSTALACAO DO SISTEMA!!

//Senha do banco
define ( "SQL_PASSWD", "");//ESSA SENHA É A SENHA PADRAO CRIADA NA INSTALACAO DO SISTEMA. É RECOMENDÁVEL A ALTERACAO DA MESMA NO MYSQL.
//Servidor do banco
define ( "SQL_SERVER", "localhost"); //SE O BANCO DE DADOS ESTIVER EM UM SERVIDOR DIFERENTE DO SERVIDOR WEB DEVE-SE ALTERAR O VALOR "localhost"
//Nome do banco
define ( "SQL_DB", "ocomon_rc6");//NOME DO BANCO DE DADOS. O PADRÃO DESSA VERSÃO É: ocomon_rc6

Meu arquivo de conexão com o banco esta configurado assim:



/var/www/html/ocomon/includes/classes/conecta.class.php


$this->con=mysql_connect(localhost,root)or die(mysql_error());

#################################################################

"No database selected"

OK ele diz que não há nenhum database selecionado, então no diretorio  "/var/www/html/ocomon/includes/classes/conecta.class.php" eu edito o arquivo colocando o nome do "database" na linha "
$this->con=mysql_connect(localhost,root,ocomon_rc6)or die(mysql_error());" ai ele não inicia a pagina de logon do ocomon e da a seguinte mensagem abaixo:

Access denied for user 'root'@'localhost' (using password: YES)

Pedindo pra min usar a senha novamente, eu coloco senha pra o usuário "root" mais não funciona.

Por favor se tiverem alguma dica eu agradeço!
Voltar ao Topo Ir em baixo
Ver perfil do usuário
FabioRK

avatar

Mensagens : 371
Data de inscrição : 14/09/2009
Idade : 37
Localização : Carazinho - RS

MensagemAssunto: Re: [RESOLVIDO]OcoMon não abre a página inicial de logon   Dom Abr 12, 2015 6:48 pm

Claudevan.

Pelo que sei a base trabalha com o usuário "ocomon" conforme o manual de instalação:
Citação :
Para importar o Script diretamente pelo MySQL (linha de comando) faça da seguinte forma:
Dentro do diretório do MYSQL no seu servidor digite:
mysql -u root -p < /caminho/para/o/arquivo/DB_OCOMON_2.0RC6_FULL.SQL (o sistema irá solicitar a senha do usuário root do MySQL)

Ao importar o arquivo de intruções SQL será criado um banco com o nome "ocomon_rc6".
Também será criado um usuário "ocomon" no banco de dados com a senha padrão "senha_ocomon_mysql".
É recomendável alterar essa senha no MySQL após a instalação do sistema.

Caso queira que a base tenha outro nome (ao invés de "ocomon_rc6"), edite diretamente no arquivo "DB_OCOMON_2.0RC6_FULL.SQL" (3 entradas no início do arquivo) antes de realizar a importação do mesmo e não esqueça de alterar no arquivo includes/config.inc.php também (dentro do pacote do OcoMon).

O início do script da base de dados (DB_OCOMON_2.0RC6_FULL.SQL) está assim:
Citação :
/*!40101 SET NAMES utf8 */;

CREATE DATABASE /*!32312 IF NOT EXISTS*/`ocomon_rc6` /*!40100 DEFAULT CHARACTER SET utf8 */;

CREATE USER 'ocomon'@'localhost' IDENTIFIED BY 'senha_ocomon_mysql';
GRANT SELECT , INSERT , UPDATE , DELETE ON `ocomon_rc6` . * TO 'ocomon'@'localhost';

USE `ocomon_rc6`;
Edita o arquivo da base e já troca a senha para o usuário "ocomon" depois recria a base.
E no teu arquivo config.inc.php utiliza o usuário "ocomon" para conectar na base.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
claudevan



Mensagens : 14
Data de inscrição : 09/04/2015
Idade : 43

MensagemAssunto: OcoMon não abre a página inicial de logon   Dom Abr 12, 2015 8:50 pm

Ok... obrigado pela ajuda, o erro estava no arquivo de conexão, fiz a modificação abaixo e conectou normalmente!

EM:
/var/www/html/ocomon/includes/classes/conecta.class.php

Antes:
$this->con=mysql_connect(localhost,root)or die(mysql_error());
$this->db=mysql_select_db(SQL_DB,$this->con);

Depois:
$this->con=mysql_connect(localhost,root)or die(mysql_error());
$this->db=mysql_select_db(ocomon_rc6,$this->con);
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Conteúdo patrocinado




MensagemAssunto: Re: [RESOLVIDO]OcoMon não abre a página inicial de logon   

Voltar ao Topo Ir em baixo
 
[RESOLVIDO]OcoMon não abre a página inicial de logon
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» [Resolvido] Como exibir subcategorias (como na página inicial)?
» PROBLEMA PÁGINA INICIAL HOTSPOT
» [Resolvido] Exibir o título da mensagem na página inicial
» Mensagem acima do fóruns na página inicial
» mikrotik ,não a abre a página google

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
Suporte não-oficial ao OcoMon :: Sua primeira categoria :: GERAL :: Instalação-
Ir para: