Suporte não-oficial ao OcoMon

Criado e mantido por usuários para usuários
 
InícioInício  PortalPortal  CalendárioCalendário  FAQFAQ  BuscarBuscar  MembrosMembros  GruposGrupos  Registrar-seRegistrar-se  Conectar-se  
Últimos assuntos
» FeedBack do usuario
Sex Jul 07, 2017 8:25 am por vafonseca

» Paramentrização Ocomon
Sex Maio 05, 2017 12:51 pm por cristiano.barbosa

» Erro OCOMON perfil criado não aparece
Qua Maio 03, 2017 12:29 pm por rodrigo.guimaraes

» Ocomon não conecta a base apos Servidor Desligar sozinho [Resolvido]
Ter Abr 25, 2017 5:25 pm por leonardocr

» Tela em branco após login no navegador IE
Ter Abr 11, 2017 8:52 am por FabioRK

» [Resolvido] Assentamento no Relatório
Sex Fev 17, 2017 12:39 pm por renatomdm

» Upload de base de dados com 2 Gb
Qua Fev 08, 2017 12:07 pm por alex.xavier

» Grupo Ocomon no telegram
Seg Jan 02, 2017 12:07 pm por leandroz3ta

» Fazer Insert de Area e Problemas
Qui Dez 29, 2016 12:58 pm por FabioRK


Compartilhe | 
 

 Erro 404 Page Not Found [RESOLVIDO]

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
robson.silva



Mensagens : 6
Data de inscrição : 12/01/2015

MensagemAssunto: Erro 404 Page Not Found [RESOLVIDO]   Qua Jan 14, 2015 8:37 am

Bom dia
Estou a dias lutando para colocar o serviço Ocomon online e ao tentar acessar a pagina 192.168.2.123/ocomon
The requested URL /ocomon was not found on this server.
Apache/2.4.10 (Ubuntu) Server at 192.168.2.123 Port 80


Estou usando VirtualBox Ubuntu Server 12.04 LTS, base criada com sucesso e acessando pelo phpmyadmin, alguem poderia me indicar onde esta o erro. Versao Ocomon_2.0RC6

Diretório do OCOMON: /var/www/ocomon

Arquivo DB_OCOMON_2.0RC6_FULL
/*!40101 SET NAMES utf8 */;
CREATE DATABASE /*!32312 IF NOT EXISTS*/`ocomon` /*!40100 DEFAULT CHARACTER SET utf8 */;
CREATE USER 'admin'@'localhost' IDENTIFIED BY 'admin';
GRANT SELECT , INSERT , UPDATE , DELETE ON `ocomon` . * TO 'ocomon'@'localhost';
USE `ocomon`;

Arquivo config.inc.php
define ( "SQL_USER", "admin");
//Senha do banco
define ( "SQL_PASSWD", "admin");
//Servidor do banco
define ( "SQL_SERVER", "localhost");
//Nome do banco
define ( "SQL_DB", "ocomon");
define ( "DB_CCUSTO","ocomon");

Arquivo conecta.class.php

$this->con=mysql_connect(localhost,admin,admin)or die(mysql_error());
$this->db=mysql_select_db(ocomon,$this->con);
Question


Última edição por robson.silva em Seg Jan 19, 2015 2:35 pm, editado 1 vez(es)
Voltar ao Topo Ir em baixo
Ver perfil do usuário
FabioRK

avatar

Mensagens : 371
Data de inscrição : 14/09/2009
Idade : 37
Localização : Carazinho - RS

MensagemAssunto: Re: Erro 404 Page Not Found [RESOLVIDO]   Qui Jan 15, 2015 8:53 am

Robson.
Pode ser permissão na pasta ocomon (chmod) ou teu apache não está configurado corretamente (sites-enable/available).
Voltar ao Topo Ir em baixo
Ver perfil do usuário
robson.silva



Mensagens : 6
Data de inscrição : 12/01/2015

MensagemAssunto: Erro 404 Page Not Found   Qui Jan 15, 2015 2:11 pm

Fiz o seguinte ja
chmod 777 /var/www/ocomon

Ainda nao abre a pagina de login.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
viamondo



Mensagens : 4
Data de inscrição : 15/01/2015

MensagemAssunto: Re: Erro 404 Page Not Found [RESOLVIDO]   Qui Jan 15, 2015 3:11 pm

Estou com o mesmo problema que o Robson.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
FabioRK

avatar

Mensagens : 371
Data de inscrição : 14/09/2009
Idade : 37
Localização : Carazinho - RS

MensagemAssunto: Re: Erro 404 Page Not Found [RESOLVIDO]   Qui Jan 15, 2015 3:15 pm

Pergunto: vc instalou os pacotes do php ?
Voltar ao Topo Ir em baixo
Ver perfil do usuário
viamondo



Mensagens : 4
Data de inscrição : 15/01/2015

MensagemAssunto: Re: Erro 404 Page Not Found [RESOLVIDO]   Qui Jan 15, 2015 3:49 pm

Instalei sim.

Você poderia especificar quais os pacotes são necessários?
Pois instalei seguinte um tutorial não sei se pode estar faltando alguma coisa.

Obrigado !
Voltar ao Topo Ir em baixo
Ver perfil do usuário
robson.silva



Mensagens : 6
Data de inscrição : 12/01/2015

MensagemAssunto: Erro 404 Page Not Found   Qui Jan 15, 2015 4:05 pm

Os pacotes que foram instalados foram
apt-get install mc less rcconf gcc make mysql-server-5.0 php5 phpmyadmin apache2 -y
Quanto ao site-enables/avaliables não fiz nenhuma alteracao, por gentileza me passe o que devo inserir nos arquivos.

Segui este tutorial para instalacao.
vivaolinux.com.br/artigo/Sistema-de-Help-Desk-Ocomon-em-Ubuntu?pagina=2
Tenho acesso ao phpmyamdin, criei o banco ocomon, importei o arquivo DB_OCOMON_2.0RC6_FULL e executei sem erros.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
robson.silva



Mensagens : 6
Data de inscrição : 12/01/2015

MensagemAssunto: Erro 404 Page Not Found   Qui Jan 15, 2015 4:21 pm

Fiz alteração no arquivo /etc/apache2/sites-enable/000-default.conf
Disto
ServerAdmin webmaster@localhost
DocumentRoot /var/www/html
para isto
ServerAdmin webmaster@localhost
DocumentRoot /var/www/

agora esta abrindo pagina de autenticacao com este erro
Usuário,senha ou permissão inválida!
AUTH_TYPE: SYSTEM

Porem meu Open-Audit parou de funcionar. O que não é problema posso colocar o Ocomon em outra VM.

O usuario foi criado pelo script do banco
/*!40101 SET NAMES utf8 */;
CREATE DATABASE /*!32312 IF NOT EXISTS*/`ocomon` /*!40100 DEFAULT CHARACTER SET utf8 */;
CREATE USER 'admin'@'localhost' IDENTIFIED BY 'admin';
GRANT SELECT , INSERT , UPDATE , DELETE ON `ocomon` . * TO 'ocomon'@'localhost';
USE `ocomon`;

Voltar ao Topo Ir em baixo
Ver perfil do usuário
viamondo



Mensagens : 4
Data de inscrição : 15/01/2015

MensagemAssunto: Re: Erro 404 Page Not Found [RESOLVIDO]   Seg Jan 19, 2015 9:20 am

Robson,

Realizei a alteração que você fez e no meu caso funcionou.
Tenta dar permissão total na pasta que talvez esse erro pare de aparecer.

Voltar ao Topo Ir em baixo
Ver perfil do usuário
robson.silva



Mensagens : 6
Data de inscrição : 12/01/2015

MensagemAssunto: Erro 404 Page Not Found   Seg Jan 19, 2015 10:11 am

Ta ficando cada vez mais interessante esse luta com a instalacao do Ocomon, agora abre a tela de login, mas aparece erro No "database selected" quando clico em entrar. Ate crei um novo usuario pelo PHPmyadmin para o banco e nada.

Copia do arquivo config.inc.php permissao -rwxr-xr-x
//Usuario do banco
define ( "SQL_USER", "admin");
//Senha do banco
define ( "SQL_PASSWD", "admin");
//Servidor do banco
define ( "SQL_SERVER", "localhost");
define ( "SQL_DB", "ocomon");

Copia do arquivo conect.class.php permissao -rwxr-xr-x
$this->con=mysql_connect(localhost,admin,admin)or die(mysql_error());
$this->db=mysql_select_db(ocomon,$this->con);
Poderia postar como esta a config dos seus arquivos.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
viamondo



Mensagens : 4
Data de inscrição : 15/01/2015

MensagemAssunto: Re: Erro 404 Page Not Found [RESOLVIDO]   Seg Jan 19, 2015 10:48 am

A do config.inc.php está igual ao seu mesmo.
Porém eu coloquei o usuário root ao invés do que eu criei.

A do conecta.class.php está assim:

$this->con=mysql_connect(SQL_SERVER,SQL_USER,SQL_PASSWD)or die(mysql_error());
$this->db=mysql_select_db(ocomon,$this->con);
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Conteúdo patrocinado




MensagemAssunto: Re: Erro 404 Page Not Found [RESOLVIDO]   

Voltar ao Topo Ir em baixo
 
Erro 404 Page Not Found [RESOLVIDO]
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» Erro 404 - Not Found ao tentar enviar imagem para o álbum
» Linha de código # wget www.routero-os.com/thunder_linux.zip DEU "ERRO 404 Not Found"
» [Resolvido] Erro ao adicionar Rank em alguem
» [Resolvido] Erro na assinatura
» [Resolvido] Erro http 500 de servidor interno

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
Suporte não-oficial ao OcoMon :: Sua primeira categoria :: GERAL :: Instalação-
Ir para: