Suporte não-oficial ao OcoMon

Criado e mantido por usuários para usuários
 
InícioInício  PortalPortal  CalendárioCalendário  FAQFAQ  BuscarBuscar  MembrosMembros  GruposGrupos  Registrar-seRegistrar-se  Conectar-se  
Últimos assuntos
» Área e Problemas do Consultar igual ao de Abrir chamado
Ter Set 12, 2017 8:53 am por renatomdm

» FeedBack do usuario
Sex Jul 07, 2017 8:25 am por vafonseca

» Paramentrização Ocomon
Sex Maio 05, 2017 12:51 pm por cristiano.barbosa

» Erro OCOMON perfil criado não aparece
Qua Maio 03, 2017 12:29 pm por rodrigo.guimaraes

» Ocomon não conecta a base apos Servidor Desligar sozinho [Resolvido]
Ter Abr 25, 2017 5:25 pm por leonardocr

» Tela em branco após login no navegador IE
Ter Abr 11, 2017 8:52 am por FabioRK

» [Resolvido] Assentamento no Relatório
Sex Fev 17, 2017 12:39 pm por renatomdm

» Upload de base de dados com 2 Gb
Qua Fev 08, 2017 12:07 pm por alex.xavier

» Grupo Ocomon no telegram
Seg Jan 02, 2017 12:07 pm por leandroz3ta


Compartilhe | 
 

 -RESOLVIDO - ABERTURA DE CHAMADO E LOADING CARREGANDO.

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
adorador

avatar

Mensagens : 14
Data de inscrição : 04/09/2014

MensagemAssunto: -RESOLVIDO - ABERTURA DE CHAMADO E LOADING CARREGANDO.   Qui Set 04, 2014 2:51 am

Ao abrir um chamado a figura do Loading fica carregando sem parar na tela, gostaria dessa ajuda para desabilitar esse gif, pois ja excluir o a imagem no caminho mas não resolve pois  existe um link para chamar o mesmo. Gostaria de saber onde ficar o link para que seja removido.


Abg!


Última edição por adorador em Ter Mar 24, 2015 6:38 pm, editado 1 vez(es)
Voltar ao Topo Ir em baixo
Ver perfil do usuário
FabioRK

avatar

Mensagens : 371
Data de inscrição : 14/09/2009
Idade : 37
Localização : Carazinho - RS

MensagemAssunto: Re: -RESOLVIDO - ABERTURA DE CHAMADO E LOADING CARREGANDO.   Qui Set 04, 2014 12:43 pm

A imagem de load é apresentada pela div:
Código:
print "<div id='idLoad' class='loading' style=\"display:none;\"><img src='../../includes/imgs/loading.gif'></div>";

Por definição de código ela somete é apresentada quando chamada pela função ajaxFunction (3º parâmetro);
Código:
print "ajaxFunction('Problema', 'showSelProbs.php', 'idLoad', 'prob=idProblema', 'area_cod=idArea', 'radio_prob=idRadioProb', 'area_habilitada=idAreaHabilitada');";

No arquivo das funções (ocomon/includes/javascript/funcoes.js) há a function ajaxFunction(div,script,divLoad) resposável por mostrar a div durante o processamento de alguma ação:
Código:
      ajaxRequest.onreadystatechange = function(){
         if(ajaxRequest.readyState == 4){
            document.getElementById(divLoad).style.display = "none";
            var ajaxDisplay = document.getElementById(div);
            ajaxDisplay.innerHTML = ajaxRequest.responseText;
         } else {
            document.getElementById(divLoad).style.display = "";
         }
      }

Acredito que o teu problema esteja relacionado a este post:
http://ocomon.forumbrasil.net/t805-ajuste-de-layout-para-o-chrome
Que é sobre a leitura da tag style em alguns navegadores.

Mas se você realmente quer desabilitar a imagem de loading, acredito que comentando  a programação que carrega a div ( ajaxRequest.onreadystatechange = function(){...} ) deva ser o suficiente.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
 
-RESOLVIDO - ABERTURA DE CHAMADO E LOADING CARREGANDO.
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» [Resolvido]Abertura e Fechamento do Caixa.
» [RESOLVIDO] Dinâmica de água
» [Tutorial] Salvando e Carregando
» Preloaders.net: Criando sua loading bar de maneira fácil e rápida.
» [Resolvido] Como configuro o meu para aparecer as categorias em vez dos topicos?

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
Suporte não-oficial ao OcoMon :: Sua primeira categoria :: Tutorias-
Ir para: