Suporte não-oficial ao OcoMon

Criado e mantido por usuários para usuários
 
InícioInício  PortalPortal  CalendárioCalendário  FAQFAQ  BuscarBuscar  MembrosMembros  GruposGrupos  Registrar-seRegistrar-se  Conectar-se  
Últimos assuntos

Compartilhe | 
 

 Erro ao salvar registros com acentuação

Ir em baixo 
AutorMensagem
rschaferinfo



Mensagens : 4
Data de inscrição : 11/06/2012
Localização : Curitiba - PR

MensagemAssunto: Erro ao salvar registros com acentuação   Ter Ago 06, 2013 10:35 am

Bom dia meus amigos,
Estou com um grande problema, toda vez que salvo um registro com acentuação, o mesmo grava em branco no BD
estou colocando o print com o exemplo das imagens, não sei mais o que fazer, já criei o banco com a linguagem modificada para latin1, utf8, ja reinstalei a base, mudei as linguagens das tabelas na mão e nada, no banco se eu salvar com acentuação fica tranquilo, agora se eu salvo via sistema não salva... como na imagem abaixo. Estou a dias tentando resolver mas sempre me deparo com esse problema.
Alguém pode me dar uma luz?? não sei mais o que fazer mesmo.

Exemplo de algumas tabelas no banco

Código:
Tabela Ascendente        Registros    Tipo    Colação    Tamanho    Sobrecarga
   areaXarea_abrechamado    1    MyISAM    latin1_swedish_ci 3.0 KB    -
   assentamentos    Visualizar Visualizar    Estrutura Estrutura    Procurar Procurar    Inserir Inserir    Limpar Limpar    Eliminar Eliminar    0    InnoDB    latin1_swedish_ci    48.0 KB    -
   assistencia    Visualizar Visualizar    Estrutura Estrutura    Procurar Procurar    Inserir Inserir    Limpar Limpar    Eliminar Eliminar    3    InnoDB    latin1_swedish_ci    16.0 KB    -
   avisos    Visualizar Visualizar    Estrutura Estrutura    Procurar Procurar    Inserir Inserir    Limpar Limpar    Eliminar Eliminar    0    InnoDB    latin1_swedish_ci    16.0 KB    -
   categorias    Visualizar Visualizar    Estrutura Estrutura    Procurar Procurar    Inserir Inserir    Limpar Limpar    Eliminar Eliminar    11    InnoDB    latin1_swedish_ci    16.0 KB    -
   categoriaXproblema_sistemas    Visualizar Visualizar    Estrutura Estrutura    Procurar Procurar    Inserir Inserir    Limpar Limpar    Eliminar Eliminar    0    InnoDB    latin1_swedish_ci    32.0 KB    -
   cat_problema_sistemas    Visualizar Visualizar    Estrutura Estrutura    Procurar Procurar    Inserir Inserir    Limpar Limpar    Eliminar Eliminar    0    InnoDB    latin1_swedish_ci    16.0 KB    





Att.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
rschaferinfo



Mensagens : 4
Data de inscrição : 11/06/2012
Localização : Curitiba - PR

MensagemAssunto: Re: Erro ao salvar registros com acentuação   Ter Ago 06, 2013 2:29 pm

rschaferinfo escreveu:
Bom dia meus amigos,
Estou com um grande problema, toda vez que salvo um registro com acentuação, o mesmo grava em branco no BD
estou colocando o print com o exemplo das imagens, não sei mais o que fazer, já criei o banco com a linguagem modificada para latin1, utf8, ja reinstalei a base, mudei as linguagens das tabelas na mão e nada, no banco se eu salvar com acentuação fica tranquilo, agora se eu salvo via sistema não salva... como na imagem abaixo. Estou a dias tentando resolver mas sempre me deparo com esse problema.
Alguém pode me dar uma luz?? não sei mais o que fazer mesmo.

Exemplo de algumas tabelas no banco

Código:
Tabela Ascendente        Registros    Tipo    Colação    Tamanho    Sobrecarga
   areaXarea_abrechamado    1    MyISAM    latin1_swedish_ci 3.0 KB    -
   assentamentos    Visualizar Visualizar    Estrutura Estrutura    Procurar Procurar    Inserir Inserir    Limpar Limpar    Eliminar Eliminar    0    InnoDB    latin1_swedish_ci    48.0 KB    -
   assistencia    Visualizar Visualizar    Estrutura Estrutura    Procurar Procurar    Inserir Inserir    Limpar Limpar    Eliminar Eliminar    3    InnoDB    latin1_swedish_ci    16.0 KB    -
   avisos    Visualizar Visualizar    Estrutura Estrutura    Procurar Procurar    Inserir Inserir    Limpar Limpar    Eliminar Eliminar    0    InnoDB    latin1_swedish_ci    16.0 KB    -
   categorias    Visualizar Visualizar    Estrutura Estrutura    Procurar Procurar    Inserir Inserir    Limpar Limpar    Eliminar Eliminar    11    InnoDB    latin1_swedish_ci    16.0 KB    -
   categoriaXproblema_sistemas    Visualizar Visualizar    Estrutura Estrutura    Procurar Procurar    Inserir Inserir    Limpar Limpar    Eliminar Eliminar    0    InnoDB    latin1_swedish_ci    32.0 KB    -
   cat_problema_sistemas    Visualizar Visualizar    Estrutura Estrutura    Procurar Procurar    Inserir Inserir    Limpar Limpar    Eliminar Eliminar    0    InnoDB    latin1_swedish_ci    16.0 KB    





Att.

Consegui resolver um problema parecido com o seu, mas o meu estava em todas as áreas, onde eu colocava acentuação ficava em branco no banco.

O que fiz foi mudar a linguagem do Apache para UTF-8, então o mesmo está sem maiores problemas para salvar os registros.

eu mudei o charset no linux Debian, o qual é a distro que utilizo.

nano /etc/apache2/conf.d/charset

e tire o comentário do #AddDefaultCharset UTF-8
Ficando AddDefaultCharset UTF-8

Porém estou com problema na estética com o icone de ? na acentuação da página, mas os registros que vão pro banco vão completos.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
 
Erro ao salvar registros com acentuação
Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» Mensagem de erro ao salvar o CSS
» Erro ao salvar meu css
» [Tutorial]Corringindo erro de salvar em GIF ANIMADO no Photoshop[By battata]]
» [Resolvido]Problemas ao salvar registros no formulário
» erro com projeção esquisito.....

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
Suporte não-oficial ao OcoMon :: Sua primeira categoria :: GERAL :: Base de Dados-
Ir para: