Suporte não-oficial ao OcoMon

Criado e mantido por usuários para usuários
 
InícioInício  PortalPortal  CalendárioCalendário  FAQFAQ  BuscarBuscar  MembrosMembros  GruposGrupos  Registrar-seRegistrar-se  Conectar-se  
Últimos assuntos
» Área e Problemas do Consultar igual ao de Abrir chamado
Ter Set 12, 2017 8:53 am por renatomdm

» FeedBack do usuario
Sex Jul 07, 2017 8:25 am por vafonseca

» Paramentrização Ocomon
Sex Maio 05, 2017 12:51 pm por cristiano.barbosa

» Erro OCOMON perfil criado não aparece
Qua Maio 03, 2017 12:29 pm por rodrigo.guimaraes

» Ocomon não conecta a base apos Servidor Desligar sozinho [Resolvido]
Ter Abr 25, 2017 5:25 pm por leonardocr

» Tela em branco após login no navegador IE
Ter Abr 11, 2017 8:52 am por FabioRK

» [Resolvido] Assentamento no Relatório
Sex Fev 17, 2017 12:39 pm por renatomdm

» Upload de base de dados com 2 Gb
Qua Fev 08, 2017 12:07 pm por alex.xavier

» Grupo Ocomon no telegram
Seg Jan 02, 2017 12:07 pm por leandroz3ta


Compartilhe | 
 

 Problema no script SQL na instalação

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
lingnau



Mensagens : 3
Data de inscrição : 05/10/2011

MensagemAssunto: Problema no script SQL na instalação   Qua Out 05, 2011 11:07 am

Bom dia/tarde/noite a todos.
Sou novo ao ocomon, estou tendo problemas na execução do script SQL de instalação.
Tentei tanto pela linha de comando quanto pelo MySQL workbench e não tive sucesso.

Meu servidor:

Windows Server 2008 R2 X64
Apache 2.2
MySQL 5.5
PHP 5.2

Durante a execução ocorre o seguinte erro:

Código:
-- Insere o usuario ADMIN

INSERT INTO `usuarios` ( `user_id` , `login` , `nome` , `password` , `data_inc` , `data_admis` , `email` , `fone` , `nivel` , `AREA` )
VALUES ('', 'admin', 'Administrador do Sistema', '21232f297a57a5a743894a0e4a801fc3', now(), now() , 'admin**@**yourdomain.com' , '123456' , 1 , '1')

Error Code: 1366. Incorrect integer value: '' for column 'user_id' at row 1

Buscando no google cheguei num post oficial sugerindo alterar TYPE = MYISAM para ENGINE = MYISAM.
Fiz o procedimento sugerido, substitui todas as ocorrências no script mas ao executar o script, continua ocorrendo o erro. Não sei mais o que fazer.

Se alguém puder me ajudar, ficaria grato.
Obrigado.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Jhonathan



Mensagens : 10
Data de inscrição : 24/01/2012

MensagemAssunto: Re: Problema no script SQL na instalação   Qui Jan 26, 2012 6:23 pm

Boa tarde, Lingnau!

Me parece que vc fez as instalações individualmente do PHP MySQL ect, correto?
Com o pacote do Xampp eu otive sucesso na versão Xampp-win32-1.7.3.

E tambem tive sucesso ao fazer a instalação com o IIS7
Segue a configuração.

Boa tarde, Pessoal!

Eu fiz a instalação diversas vezes com o XAMPP sem problemas, mas com o IIS foi um pouco trabalhoso mas obtive sucesso.

Sistema operacional Windows server 2008 R2
- PHP 5.3 (Atraves do Microsoft Web Platform Installer 3.0)
- mysql-essential-4.1.21-win32
- IIS 7.0
- Browser Firefox ou IE 9.0
- mysql-gui-tools-5.0-r17-win32
- Ocomon_2.0-RC6

Tive que fazer estas alterações no PHP.INI para funcionar.

Short_open_tag = off > Short_open_tag = on

;open_basedir = > open_basedir = “C:\Inetpub”

extension_dir = “./” > extension_dir = “C:\Program Files (x86)\PHP\v5.3\ext”

;cgi.force_redirect = 1 > cgi.force_redirect = 0

; cgi.fix_pathinfo = 1 > cgi.fix_pathinfo = 1

;fastcgi.impersonate = 1; > fastcgi.impersonate = 1

Extension
;extension=php_mysql.dll > extension=php_mysql.dll
upload_tmp_dir="C:\Windows\Temp"
session.save_path="C:\windows\temp"

E do resto fiz as configurações normais do ocomon, porem quando estava fazendo com outras versoes como vc eu tambem obtive este erro que vc esta tendo.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
 
Problema no script SQL na instalação
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
Suporte não-oficial ao OcoMon :: Sua primeira categoria :: GERAL :: Instalação-
Ir para: